macOS Extractor v1.4.2 Beta 3 - Changes, Bug Fixes, Enhancements etc.

Discussion in 'Beta Testing' started by admin, Feb 27, 2017.

  1. admin

    admin Isiah Johnson (Admin) Staff Member

    This thread is intended for the discussion of macOS Extractor Beta

    Here is macOS Extractor v1.4.2 Beta 3. This Beta is for Developers and Beta Testers who can diagnose their Macs if something goes wrong.

    A macOSE update is recommended to assist you in installing macOS Sierra, El Capitan, Yosemite, and Mavericks on your old Mac. Also, by updating this patching software on your Mac, you can enjoy various additional features and enhanced security. Always use to the latest version.
    Never download this from any other provider. All links must be from these forums or directly from our server. This is to ensure that nothing was tampered with and that you have the most reliable and tested stuff.

    This update includes the following:
    • Fixed issue where the Graphical Installer fails after clearing kernel cache
    • Addresses issue where the AutoPatch refuses to complete all of its tasks within the Target Partition/Image
    • Fixes issue where some scripts are in rich text formatting (ugh...who did that?)
    • Replaces brightness app with a new app recommended by a member is the Yosemite thread.
    • Smart OS detection
    • Installer Logs now echo its current process to help diagnose where more issues may occur.
    Developer Focus Area:
    • Booting into OS X El Capitan and macOS Sierra Installer
    • Performance
    • General Reliability
    • Rootless Disabling



    Download Size:
    70 - 170 MB


    Prerequisites
    Tested Macs listed below. Here are the minimum requirements:
    - Running 10.7 Lion
    - At least 2GB of RAM.
    - A copy of Yosemite or Mavericks in Applications Folder (.app file preferred)
    - 15 GB of free space from USB or HDD Partition.


    -MacBook2,x
    -MacBook3,x
    -MacBook4,x
    -MacBookPro2,x
    -MacBookAir1,1
    -MacMini1,x (C2D upgraded)
    -MacMini2,x
    -iMac4,x (C2D can be upgraded)
    -iMac5,x


    We DON'T assist with Hackintosh. All private messages/emails involving installing OS X on non-Apple hardware will be redirected to another support team.

    You are not allowed to view links. Register or Login

    [​IMG]
     
    Last edited: Mar 17, 2017
  2. Brainzyy

    Brainzyy New Member

    I just tried this on my Macbook4.1 running Lion, but the Autopatch is still failing.

    EDIT: I was trying to install ML to a 2nd partition.
     
  3. admin

    admin Isiah Johnson (Admin) Staff Member

    Do you have the installer log?
     
  4. Brainzyy

    Brainzyy New Member

    Sorry for the stupid question, but where can I find the log?
     
  5. admin

    admin Isiah Johnson (Admin) Staff Member

    When you open the AutoPatch. Go to the Menu Bar > Window > Installer Log
    You are not allowed to view links. Register or Login

    A new Window should show up. Now you can Change the Detail Level to 'Show All Logs' and save it.
    You are not allowed to view links. Register or Login
     
  6. Brainzyy

    Brainzyy New Member

    Sorry for the late response. Here's the log.
    I can see where it goes wrong though. The autopatch assumes that the volume that gets mounted by the installer is called "OS X Base System", while with the Mountain Lion installer it is actually called "Mac OS X Install ESD".
    And yes, I'm using the official installer .app from the app store :)
     

    Attached Files:

  7. admin

    admin Isiah Johnson (Admin) Staff Member

    I will make note of this in the next beta tomorrow. Thanks!
     
  8. Brainzyy

    Brainzyy New Member

    I have just tested the new version and it can create the bootable USB now.

    However, I run into a new problem.
    The bootable usb isn't able to boot.

    If I try booting into it it just shows a stop sign and doesn't do anything.
    If I try to boot into it with refind, it gives an error saying "could not open mach_kernel".

    Offtopic: Your forum seems a little broken, because I can't post a reply anywhere and I can't write the body of a new thread. And to reply to you I first had to post an empty message and then edit it because it wouldn't show me anything to write a reply the first time.

    EDIT: here is the installer log You are not allowed to view links. Register or Login (as you can see there are still a lot of "no such file or directory" errors.
     
    Last edited: Mar 19, 2017
  9. admin

    admin Isiah Johnson (Admin) Staff Member

    I will look into this forum problem. It may be that these categories are not 'Forum' Nodes.
    As for the AutoPatch. I can definitely see where commands are breaking. The script views the OpenGL.framework as a directory so it fails to replace the contents of it with the patched version of it. I also need to add more conditional statements between Mountain Lion and the other OSs because of how Apple renamed 'Mac OS X Base System" Can you send me your postinst script via You are not allowed to view links. Register or Login?
     
  10. Beta Tester

    Beta Tester New Member

    Test Test Test
     
  11. Beta Tester

    Beta Tester New Member

    Test Testy Test
     
  12. Jsndll738

    Jsndll738 New Member Staff Member

    Can you send us screenshot of what's happening when you try to reply as well?
     
  13. Brainzyy

    Brainzyy New Member

    Here are some screens of how it looks:

    1:
    [​IMG]

    2:
    [​IMG]

    If it isn't clear, I just can't type anything anywhere (tested on chrome (windows) and firefox(linux))
     
  14. Brainzyy

    Brainzyy New Member

    Sent you an email with the script. For the images see the post above this one.
     

Share This Page

Share This Page

Join Swagbucks!
You Can Get Free Gift Cards For Shopping, Searching and Discovering What is Online at Swagbucks.com